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Introduction to ESRI's ArcGIS I 
Matt Dunbar 

Autumn, 2017 CSDE Workshop 
 

 
The goal of these exercises is to give you a general overview of what ESRI's GIS software has to 
offer. Keep in mind we have only a limited amount of time, so our focus today will be breadth 
rather than depth! Don't worry, we'll offer more workshops in the future. Please feel free to ask 
questions as we proceed if something doesn't make sense, and certainly be vocal if find you've 
missed a step. Please keep pace with the workshop! 
 

 

Exercise Download & Setup 

1. Open a Windows File Explore and Navigate to” C:\temp\”.  
NOTE: This is the only location you can write files in the CSSCR computer Lab. 
 

2. To avoid confusion, delete any existing folders with names containing “csde” and “gis”.   
 

3. Go to the following web site: http://csde.washington.edu/. Navigate to Training-
>Workshops, and select the “Introduction to GIS Workshop” link, and then click the  
Part 1 link from the Materials section. 
 

4. Extract the folder “csde_gis1” from CDSE_Intro_to_GIS1.zip into the folder “C:\temp\”. 

ArcGIS Applications Description  

ArcCatalog (Storing GIS Data):  
ArcCatalog allows the user to easily access and manage geographic data that is stored in 
folders on local disks or relational databases that are available on the user's network. Data 
can be copied, moved, deleted, and quickly viewed before it is added to a map. In addition, 
metadata can be either read or created using this ArcGIS application.  
 

ArcMap (Mapping GIS Data):  
ArcMap allows the user to display and query maps, create quality hardcopy maps and 
perform many spatial analysis tasks. ArcMap provides an easy transition from viewing a map 
to editing its spatial features.  
 

ArcToolbox (Analyzing GIS Data):  
ArcToolbox provides an environment for performing geoprocessing operations (i.e., 
operations that involve alteration or information extraction). Tools step the user through the 
many geoprocessing tasks. ArcToolbox is embedded in both ArcCatalog and ArcMap. *We 
won't use ArcToolbox in this exercise, but it will be important for most GIS analysis* 
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Exploring Data in ArcCatalog 

1. Start ArcCatalog: Start>Programs>ArcGIS>ArcCatalog 10.X. The ArcCatalog application 

window includes a catalog display that allows you to preview data, either spatially or as 

tables, a catalog tree for browsing the data, and several toolbars. 

 

2. If the drive you would like to work from is not in the catalog tree on the left of the 

application, you can add it.  Click the "Connect to Folder" Icon  on the main toolbar. 

Highlight your desired drive and select "OK". Your drive will now appear in the catalog.  

 

3.  We'll start by exploring the data 

you just copied to your C drive.  

Navigate to the 

"C:\temp\csde_gis1\Data\" in the 

catalog tree and highlight this 

folder. 

 

4. You will see two objects in the 

folder: "Shapefiles" and 

"FileGeodatabase.gdb." These are 

two copies of the same datasets, in 

different formats used by ArcGIS. 

Start by expanding the "Shapefile" folder in the Catalog tree. 

 

5. A shapefile dataset (.shp) is stored in a folder, is 

composed of geographic features and their 

attributes, and contains a single feature class. 

Points, lines, or polygons (areas) represent 

geographic features in a shapefile. 

 

6. Our "Shapefiles" folder contains 3 shapefile 

datasets: Counties, States, and US_Interstates. 

Two of these shapefiles contain polygon features and one contains line features. The 

name of the files and the icons used to represent them should give this away. 

 

7. There are also two tabular datasets in this folder: County_Population_Data as an Excel 

and tab-delimited Text file. Please notice the "OriginalFiles" folder, containing a backup 

copy of all the data in case you need to start over later. 

1 

1 
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8. Next, we will look at the various ways to explore GIS data in the Catalog Display. Click on 

States.shp in the catalog tree.  Select the "Preview" Tab. The geographic representation 

of the layer will now be visible.  

 

9. At the bottom of the catalog display, there is a preview drop‐down list. This allows the 

user to view either the geography or the associated attribute table for the data layer. 

Select the "Table" option. Scroll through the table to see the attributes contained 

within the counties layer. The only option available for Tabular data will be "Table". 

 

10. Finally, click on the "Description" tab in the catalog 

display. Information about the data set (Metadata) 

is displayed (such as its coordinate system, its 

spatial extent, description of its attributes, and 

descriptive information about when and how the 

data was created). Explore the other datasets in the 

"Shapefiles" folder before moving on. 

  

11. Now we'll look at another way of storing GIS data, the File Geodatabase. Expand 

"FileGeodatabase.gdb" in the catalog tree. Notice that the Geodatabase contains the 

same 3 geographic features as the shapefiles, and just one data table. The only 

difference in appearance is the grey icons. 

 

12. Use ArcCatalog to explore the geographic and table features in the geodatabase. 

 

13. Why would you use a geodatabase instead of separate shapefiles and tables? The 

Geodatabase acts like a container, to store all the data layers that make up your GIS 

project. In addition to organization, they offer improved performance for large datasets, 

enhanced control over the formatting of data and how layers interact, as well as many 

other advanced features. It is fine to start working with shapefiles, but you should be 

1 
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aware of what a geodatabase is and when it may be appropriate for your work. New in 

ArcGIS 10, ESRI has chosen the file geodatabase as the default spatial data storage 

type. Once you become familiar with GIS, it is recommended that you begin new 

projects by first creating your own file Geodatabase. 

 

14. Before we start making maps, let's look at the same data structure in Windows Explorer. 

Open Windows Explorer and navigate to "C:\temp\csde_gis\Data\". Look at the 

contents of both the "Shapefiles" folder and the "FileGeodatabase.gdb" folder. A single 

shapefile is a collection of many files with the same base file name but different 

extensions. A geodatabase is stored within one folder, but contains a large number of 

files with assorted complex names. Shapefiles can be relocated by copying ALL files with 

the same base name and various extensions. An entire File Geodatabase can be 

relocated by copying the entire folder containing the geodatabase. 

 

15. ArcGIS supports many other file formats for the various data structures used in GIS 

(vector, raster, table, etc.). Some tips for working with other data types: 

 See if ArcCatalog recognizes and will display your data's geographic or tabular 

information 

 Check the extensive and well written ArcGIS help system for your file type 

 

 

 

 

 

 

 

 

 

 

  



Page | 5  
 

Viewing Data in ArcMap 

1. Start by opening ArcMap: Start>Programs>ArcGIS>ArcMap 10. Once the software 

opens, you'll be prompted for how you'd like to begin. Select "Blank Map" and click 

"OK". You should now see a blank slate to start you GIS work. 

 

2. Your application may look different from the example, with different toolbars loaded by 

default in different locations. Use Customize>Toolbars to check only the following 

toolbars: Standard and Tools. Also, drag your toolbars to the same area of the screen 

as shown in the figure. Drag a toolbar by clicking and holding the left mouse button, 

dragging the toolbar across the screen, and releasing the button to dock the toolbar. 

 

3. Before we begin, take note of the Catalog and Search Tabs along the right side of 

ArcMap. Take note of their auto-hide behavior. We will cover their use later. 

 

4. Now let's add some of the shapefile data we looked at in ArcCatalog. On the top toolbar, 

click the Add Data Icon . When the dialog box appears, Navigate to " 

C:\temp\csde_gis1\Data\Shapefiles\" and select both "Counties.shp" and 

"States.shp" (hold down Ctrl while clicking each file name). When they are both 

selected click "Add". 
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5. Once you've added data, you should notice two changes in ArcMap. Your shapefiles 

have been added into the Layers list in the Table of Contents on the left. Also, in the 

Data View on the right, you should now see a geographic view of these files. The colors 

of your layers will vary, as ArcMap assigns new layers a single random color. 

 

6. You can turn on and off the display of layers by clicking the checkbox next to the layer 

name. Turn off the Counties Layer. Your Data View will now show the States layer, as 

the Counties layer that was covering it is no longer being displayed. Turn on the 

Counties Layer. 

 

7. You can also re-arrange the order of layers. First make sure to unselect both layers if 

they are still highlighted grey. Clear the selected layers by clicking any white area in the 

layer content panel. Next, left-click and drag the States layer name above the counties 

layer. Your Data View should again show the States Layer, even though the Counties 

layer is still turned on. When designing the appearance of your map in the data view, 

always keep in mind the layers are drawn on the screen from bottom (first) to top (last) 

like layered transparencies placed on top of each other. To finish this step, turn off the 

counties layer. 
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Map Navigation 

1. Now let's try some of the navigation features in ArcMap that allow us to move around in 

the Data View. The following sets of tools are available in ArcMap: 

 

Zoom In (Click to zoom at cursor location, or click-drag a zoom box) 

Zoom Out  

Pan (Click and drag the map around in the Data View) 

Fixed Zoom Out 

Zoom to Full Extent (Zooms the Data View out to show every layer) 

Fixed Zoom In (Click button to zoom in one level at map center) 

Go to Previous Extent (Like web browser's Back button for you Data View) 

Go to Next Extent  

 

2. Experiment with the various Navigation Tools. Notice that some tools change the 

cursor and must be used in the Data View (Zoom In/Out and Pan) while some simply 

activate when pressed (Fixed Zoom In/Out, Full Extent, Previous and Next). 

 

3. When you feel comfortable with the various tools, zoom the extent of your data view 
to the lower 48 states.  
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Saving your Map Document 

1. Now that we've got our data arranged and the extent set correctly, let's save our Map. 

In the main menu go to File>Save. Navigate to "C:\temp\csde_gis1\" and enter an 

appropriate file name (“MyFirstGIS.mxd”). 

2. What's actually being saved in this .mxd file? The following items: A list of all the layers 

and tables in the Table of Contents with their order and status, the current view in the 

Data View window, the symbolization and classification of all of your layers, table, joins, 

selections, and all map elements in the Layout View (which we'll cover later).  

 

3. What isn't saved in the mxd? Your actual GIS layers and tables. They are not stored in 
 the mxd file. Rather, the .mxd file links to these files, which are stored outside either in 

folders or in geodatabases. When you are changing how data is displayed in your map, 

you are not actually changing the data files themselves. You are simply changing how 

you are viewing them within your .mxd file. 

 

*NOTE: When you move your GIS project, you have to move your data along with the .mxd file. 

For this reason, we recommend you store your data in subdirectories below your mxd files - 

you can't store them in separate unrelated folders, otherwise ArcGIS won't be able to find your 

files!  
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Identifying and Selecting Features 

1. When you want information about a feature displayed in ArcMap, you can use the 

Identify tool. Click on the Identify tool  to turn it on.    

 

2. The Identify tool allows you to see the attributes of your data and is an easy way to 

learn about a location in a map. With the Identify tool selected, click inside of the state 

of Washington. 

 

 

 

 

 

 

 

 

 

 

 

 

3. You will see displayed a window containing all the tabular (attribute) data located in 

your States shapefile for the record corresponding to the state of Washington. These 

fields should look familiar from your exploration in ArcCatalog. Scroll through the list of 

attributes and select another few states. Close the identify window. 

 

4. Now let's revisit the attribute table for the States layer. Right-click on the "States" layer 

name in the table of contents and select "Open Attribute Table". The same complete 

table of data we looked at in ArcCatalog should now be visible on the screen. 
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5. Position the Attribute table so that you can see it as well as the Data view showing your 

map. Find the row corresponding to Washington state and select that feature by 

clicking on the small grey box next to FID. This will highlight the record in the attribute 

table as well as the corresponding feature in the Data view.  

 

6. Now select a second state by ctrl-clicking in another grey box. You should now see two 

rows highlighted in your table and two features highlighted on the map. 

 

7. Clear the selected features: from the main menu go to Selection>Clear Selected 

Features.  

 

8. Features can also be selected in the Data view from your map. Activate the Select 

Features tool . Now click on any state in the Data view to select that feature on the 

map and in the attribute table. 

 

9. Clicking rows in the attribute table or features in the Data view aren't the only way to 

select features, you can also build queries to search through the attribute table and 

select only features you are interested in. Create an attribute query by choosing 

Selection>Select by Attribute from the main menu. 
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10. We want to select all states with a population 

greater than 5 million in the 2000 census. First 

double-click on the "POP2000" variable name. 

Next select the greater than or equal to button (> 

=). Finally, at the end of the query string that is 

built, type 5000000. Click OK.  

 

11. You have now selected all features that match this 

query. States should be selected in your Data view 

and in your attribute table. Check the bottom of 

the attribute table to see that 20 were selected. If 

you would like to just look at the selected features 

in the attribute table, press the button labeled 

"Selected". 

 

12. Close the attribute table and clear the selected features. 

 

Layer Properties, Symbology and Labeling 

1. Each layer in our table of contents has additional properties we can view and 

manipulate. Right-click on the States layer name and select "Properties". 

 

2. The Layer Properties window 

that appears has several 

different tabs relating to various 

aspects of our data. Start by 

selecting the "Source" tab. 

Here you will find two 

important pieces of 

information. First, this tab 

shows where the data layer is 

stored. Second, this tab also 

shows the Geographic 

Coordinate System of the layer. 

Remember that a GIS data layer 

must have a defined coordinate 

system to correctly integrate with other layers.  
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3. Next, click on the "Symbology" 

tab. This is where you decide how 

features and data will be displayed 

on the map in your Data view. By 

default ArcMap displays all 

features in a layer using a single 

symbol.  

 

 

 

 

 

 

4. Let's change the symbology to show state grouped together by their geographic region, 

each region with its own unique color. Select the "Categories" option in the list on the 

left of the Symbology tab, as region is a nominal scale or category variable type. In the 

Value Field drop down menu select SUB_REGION, which is the variable we would like 

to base our color selection on. Then click the "Add All Values" button to populate the 

list with our state names. Finally, click "Apply" to update the map in our Data view. If 

you don't like the colors that were chosen, select a different "Color Ramp" from the 

Symbology tab. 
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5. By classifying geographic features into groups based on a numeric field in their attribute 

table, we can construct a thematic map. Select the "Quantities" option in the list on the 

left of the Symbology tab. In the Value Field drop down menu select POP2000, which is 

the variable we would like to base our color selection on. Once a variable is selected, the 

data will be automatically classified into 5 groups. Finally, click "Apply" to update the 

map in our Data view and see the result.  

 

 

 

 

 

 

 

 

 

 

 
6. As the Symbology tab suggests, there are many ways to represent your data in ArcMap. 

Time permitting, we'll look at the following: 

 Try changing the number of classes.  Start with 10, then try 3. What is lost or 

gained with more or fewer classes? 

 Change the Value field to Females and look at the default 5 class map. Now use 

Normalization by POP2000 to create a map of Percent Female. What does each 

map show you? 

 Make the same normalized map with Male population for comparison. 

 Investigate other Classification Methods. 

 Create a second copy of the states layer, and display another variable 

(Med_Age_Male) using Graduated Symbols. 

 Remove the second copy of the states layer by right clicking on the layer and 

selecting “Remove.” 
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NOTE: Be sure to ask any questions if you would like to see something in 

particular explained. 

 

7. The last thing we will do in the 

Layer Properties is to label the 

features in our Data view. Go to 

the "Labels" tab. Turn on labeling 

by checking the box "Label 

features in this layer". We must 

tell ArcMap what field to label our 

states feature with. Let's use the 

state name abbreviation by 

selecting "STATE_ABBR" as the 

Label Field. The defaults are fine 

for this example. Click "OK". 
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Adding and Joining Data Tables 

1. You will often find that your spatial data files do not contain all of the attributes you 

want to work with. For this example, the Counties shapefile contains far less information 

than we need to create a useful map. Turn off the States layer and turn on the Counties 

layer.  Next, open the attribute layer for Counties (right-click "Counties" and select 

"Open Attribute Table") 

 

2. The attribute table only 

contains basic geographic 

information about each 

county (name, state, FIPS 

or Federal Information 

Processing Standards code, 

etc). We will now bring in 

additional information in 

the form of tabular data to 

augment the shapefile. 

 

3. As luck would have it, you have the required tabular information in your Data directory. 

Click the Add Data Icon . When the dialog box appears, Navigate to " 

C:\temp\csde_gis1\Data\Shapefiles\". Select "County_Population_data.xls", then 

select the Excel sheet " County_Population_Data$", and click “Add”. 

 

4.  The new excel spreadsheet file has been added to the ArcMap 

document, but there is no change in the Data view. As this is 

tabular data, there is no new geographic information to display. 

However, there is a change in the Table of Contents. Notice the 

icons along the top. Adding this dataset has changed the view 

from List by Drawing Order  (showing just the map layers and 

their symbology) to List by Source  (showing all data files 

arranged by location on the computer and data type).  

 

5. You can look at the new tabular data by right-clicking the 

"County_Population_Data$" and selecting "Open". This file 

contains a large number of population-based data. Also, this table 

has the same FIPS attribute as the County shapefile. 

  H:\GIS1\Data\Shapefiles 
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6. Close the Attributes table and return the table of contents to List by Drawing Order by 

clicking on the icon . 

 

7. Now let's join the Attribute table of our Counties shapefile to the new data table. Right-

click on the Counties layer in the table of contents and select Joins and Relates > Join. 

 

 

 

 

 

 

 

 

 

 

 

8. In the Join Data Window, "Join attributes from a table" should be the option in the first 

drop down box. For the field in the layer that the 

join will be based on, select "FIPS". The remaining 

options should be selected for you as there is only 

one table in your ArcMap project and only one field 

in that table that is a likely match ("FIPS" also). 

Check your options to make sure they match and 

then select "OK". 

 

*NOTE: The data type of joined fields must be identical (e.g. 

number vs. text). This is a VERY COMMON issue, as ID fields, 

such as FIPS, are often stored as Text to allow the use of 

leading 0’s to insure consistent ID length. 
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9. Nothing will visibly change in ArcMap, but open the attribute table for the Counties 

layer to see the result. The attribute table now contains all the original data from the 

Counties shapefile, in addition to the fields contained in the .xls table. 

 

10. The joined data in the attribute table can be accessed as if it were part of the original 

shapefile, although the shapefile has not been modified. Let's create a map using a field 

from the joined table. Open the Counties Layer Properties and go to the Symbology 

Tab. Select Graduated Colors, set the Value: field "AGE_65_UP", the Normalization: 

field to "POP2000", and select a single color-based color ramp (i.e. light to dark red). 

This variable does not exhibit a distinct spatial pattern. Try selecting another variable 

that might make a more meaningful map (hint: try race/ethnicity). 
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Designing and Exporting a Map 

1. You can quickly export a copy of whatever you see in the ArcMap data view. From the 

main menu choose File>Export Map. Navigate to your" C:\temp\csde_gis1\" directory 

and select a name for your file. Save as type "PNG (*.png)" and set the Resolution to 

"300" to make a nice large image. After you export the image, use windows explorer to 

view the file. 

 

2. This approach is great for generating a quick figure for a report or publication, but what 

if you need to make a complete map product (i.e. to distribute on its own)? To do this 

we will need to use the layout and map design tools in ArcMap. This can be a lengthy 

process for a detailed map; to save time we will use a pre-defined Map Template. 

 

3. The first step in designing a map is to switch from the now-familiar Data view to the all-

new Layout View. Notice the following two small icons at the lower left of the Data view 

. Click on the icon that looks like a small sheet of paper to enter Layout view. 

 

4. The first thing you will notice is that your Data view has been replaced with something 

that looks like our original map on a sheet of paper. You should also see a new toolbar 

somewhere on your desktop. Move the new Layout toolbar somewhere convenient.  
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5. Notice all the navigation tools are replicated on the Layout toolbar (with a piece of 

paper behind them). While the original navigation tools manipulate your view of your 

geographic data, the layout navigation tools manipulate your view of the map layout 

you are designing (that piece of paper your map is now on). Take a moment to explore 

the difference between the Layout and Standard navigation tools. 

 

6. The first step to creating our map is selecting the template we would like to use. From 

the Layout navigation toolbar, select the Change Layout icon . 

 

7. The Select Template window will appear, which contains several tabs. Go to the "USA" 

tab (press right arrow button at top right). We will keep our map constrained to the 

lower 48 states, so select the "ConterminousUSA.mxt" template and click Finish. 

 

 

 

8. The new map layout should appear a little more attractive. There are still some things 

we need to fix. Templates are not an "Easy Button" approach to map making. In the next 

few steps we will 1) Fix the map projection to something more appropriate for this 

spatial extent, 2) Fix the legend and map title, and finally 3) Replace the ESRI logo. 
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9. First, to change the map projection 

double-click on the word "Layers" in the 

table of contents. In the Data Frame 

Properties window that appears, navigate 

to the "Coordinate System" tab. Notice 

that the current coordinate system is 

GCS_WGS_1984, which is actually not a 

"projected" at all (GCS or Geographic 

Coordinate System simply stores data by 

their degrees latitude and longitude, like 

on a globe. This is an easy way to store 

data, but a bad way to draw it on a map). 

 

10. From the box labeled "Select a coordinate 

system", navigate to the following folder 

"Predefined > Projected Coordinate 

Systems > Continental > North America" and select "USA Contiguous Albers Equal Area 

Conic". Click "OK" to set the new map projection. The warning message that appears 

lets you know that your data and the new map's coordinate systems are different. Click 

"Yes" to accept the changes. Zoom and center your geographic data to maximize the 

lower 48 states it within the map display area. Do not use the layout zoom. 
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11. Next we will fix the map legend. Use the Layout zoom 

tool to enlarge the lower left portion of the map 

where the legend is located. First we will resize the 

Legend. From the Standard toolbar, turn on the Select 

Elements tool . Click on the Legend to activate it's 

resize controls (small green rectangles). Make the 

legend small enough to fit inside the small black box.  

 

12. Next we will remove the small word "Legend". Double click on the box containing the 

legend to open the Legend Properties. From the "Legend" tab, uncheck the "Show" 

box, and click "OK". You may need to resize the legend to fill the box correctly. 

 

13. Our next task is to fix the remaining labels in the legend. First we will change the text 

"AGE_65_UP/POP2000" to something a bit more pleasant. In the table of contents, click 

once on the text "AGE_65_UP/POP2000" to highlight it. Click the same text again to 

begin editing it. Change this text to "Percent Pop Over 65". 

 

14. Our last change to the legend will involve the labels for 

each class of data. It would be much easier to read if 

these numbers were shown as actual percentages and 

using fewer decimal places. Open the Counties feature's 

Layer Properties (right-click > Properties) and go to the 

"Symbology" tab. Next, click in the grey box "Label" and 

select "Format Labels". Change the Category: to 

"Percentage" and then select the option "The number 

represents a fraction". Finally, click the "Numeric 

Options" button, and set the "Number of decimal places" to 1.  Apply these changes by 

clicking "OK" three times. 

 

15. Moving on, let's update the Map title. Double click on the current title "Conterminous 

United States" and change the text to "Population Over Age 65 in 2000". We'll also 

need to make the text a bit smaller, so click the "Change Symbol" button, set the font 

size to 20, and click "OK" twice to apply these changes. 

 

16. We've almost finished our map! The last step will be to remove the ESRI Globe-logo 

from the lower right corner and replace it with our own. Click on the ESRI logo to 

highlight it, and press the Delete key on your keyboard to remove it. Now we'll add a 

new, more appropriate logo. Select Insert>Picture from the main menu (note the other 
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options here, as this is where you would select elements to create a map from scratch). 

Navigate to ” C:\temp\csde_gis1\Data\" and select the file "CSDE_Logo.jpg". Resize 

and place the logo in the lower right corner of the map, where the ESRI logo was. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

17. Now that we've got a decent looking map, let's save it. Instead of a image/graphic file 

format like we've already used, let's output our finished map as a .PDF file. From the 

main menu, select File > Export Map. Set the "Save as type" to "PDF (*.pdf)", name 

your file, and place it in your "C:\temp\csde_gis1\" folder. 

 

18. Use windows explorer to navigate to your map and have a look! 

 


